EmbeddedObjectAttributes Class

The EmbeddedObjectAttributes class contains attributes for embedded objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class EmbeddedObjectAttributes : AttributesBase

The EmbeddedObjectAttributes type exposes the following members.

Constructors
  NameDescription
Public methodEmbeddedObjectAttributes
Initializes a new instance of the EmbeddedObjectAttributes class that loads standard attributes.
Public methodEmbeddedObjectAttributes(String)
Initializes a new instance of the EmbeddedObjectAttributes class that loads given attributes.
Top
Properties
  NameDescription
Public propertyFrame
Gets or sets the frame.
Public propertyScaling
Gets or sets the scaling type.
Public propertyXScale
Gets or sets the X scaling value. Changing this property will set the scaling type to ScaleXY.
Public propertyYScale
Gets or sets the Y scaling value. Changing this property will set the scaling type to ScaleXY.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next