ViewCreateTopView Method

Generates a new top view on the sheet of the given drawing.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateTopView(
	Drawing drawing,
	Point viewInsertionPoint,
	ViewViewAttributes viewAttributes,
	out View view
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing in which to create the view.
viewInsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The center point of the view.
viewAttributes
Type: Tekla.Structures.DrawingViewViewAttributes
The attributes for the view to be created.
view
Type: Tekla.Structures.DrawingView
The created view is returned if the creation was successful. Otherwise, null is returned.

Return Value

Type: Boolean
True if the view was created successfully.
Exceptions
ExceptionCondition
InvalidTypeExceptionThrown if given drawing is GA drawing.
TeklaStructuresDrawingsApplicationExceptionThrown if an unknown error occurrs.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next