AnalysisDecomposedLoadAnalysisLoadTypeEnum Enumeration

Defines the analysis load types.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public enum AnalysisLoadTypeEnum
Members
  Member nameValueDescription
NOT_DEFINED0 The analysis load type is not defined.
ANALYSIS_NODAL_LOAD1001 The analysis nodal load.
ANALYSIS_MEMBER_LINE_LOADX1 The analysis member line load in the X direction.
ANALYSIS_MEMBER_LINE_LOADY2 The analysis member line load in the Y direction.
ANALYSIS_MEMBER_LINE_LOADZ3 The analysis member line load in the Z direction.
ANALYSIS_MEMBER_LINE_MOMENTX4 The analysis member line moment load in the X direction.
ANALYSIS_MEMBER_LINE_MOMENTY5 The analysis member line moment load in the Y direction.
ANALYSIS_MEMBER_LINE_MOMENTZ6 The analysis member line moment load in the Z direction.
ANALYSIS_MEMBER_POINT_LOADX7 The analysis member point load in the X direction.
ANALYSIS_MEMBER_POINT_LOADY8 The analysis member point load in the Y direction.
ANALYSIS_MEMBER_POINT_LOADZ9 The analysis member point load in the Z direction.
ANALYSIS_MEMBER_POINT_MOMENTX10 The analysis member point moment load in the X direction.
ANALYSIS_MEMBER_POINT_MOMENTY11 The analysis member point moment load in the Y direction.
ANALYSIS_MEMBER_POINT_MOMENTZ12 The analysis member point moment load in the Z direction.
ANALYSIS_MEMBER_TEMPERATURE_LOAD13 The analysis member temperature load.
ANALYSIS_PLATE_POINT_LOAD14 The analysis area point load.
ANALYSIS_PLATE_LINE_LOAD15 The analysis area line load.
ANALYSIS_PLATE_PRESSURE_LOAD16 The analysis area pressure load.
ANALYSIS_BAR_LINE_LOADX21 The analysis bar line load in the X direction.
ANALYSIS_BAR_LINE_LOADY22 The analysis bar line load in the Y direction.
ANALYSIS_BAR_LINE_LOADZ23 The analysis bar line load in the Z direction.
ANALYSIS_BAR_LINE_MOMENTX24 The analysis bar line moment load in the X direction.
ANALYSIS_BAR_LINE_MOMENTY25 The analysis bar line moment load in the Y direction.
ANALYSIS_BAR_LINE_MOMENTZ26 The analysis bar line moment load in the Z direction.
ANALYSIS_BAR_POINT_LOADX27 The analysis bar point load in the X direction.
ANALYSIS_BAR_POINT_LOADY28 The analysis bar point load in the Y direction.
ANALYSIS_BAR_POINT_LOADZ29 The analysis bar point load in the Z direction.
ANALYSIS_BAR_POINT_MOMENTX30 The analysis bar point moment load in the X direction.
ANALYSIS_BAR_POINT_MOMENTY31 The analysis bar point moment load in the Y direction.
ANALYSIS_BAR_POINT_MOMENTZ32 The analysis bar point moment load in the Z direction.
ANALYSIS_BAR_TEMPERATURE_LOAD33 The analysis bar temperature load.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next