View Constructor (ContainerView, CoordinateSystem, CoordinateSystem, AABB)

Creates a new view instance with the given coordinate systems and model area.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public View(
	ContainerView View,
	CoordinateSystem ViewCoordinateSystem,
	CoordinateSystem DisplayCoordinateSystem,
	AABB RestrictionBox
)

Parameters

View
Type: Tekla.Structures.DrawingContainerView
The container view where the view is placed.
ViewCoordinateSystem
Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the view restriction box.
DisplayCoordinateSystem
Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the display plane.
RestrictionBox
Type: Tekla.Structures.Geometry3dAABB
The restriction box describing the area of the model (in the view coordinate system).
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next