Rectangle Class

The Rectangle class defines a rectangle that is a box made of four lines with orthogonal angles.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Rectangle : ClosedGraphicObject

The Rectangle type exposes the following members.

Constructors
  NameDescription
Public methodRectangle(ViewBase, Point, Point)
Creates a new rectangle instance with two points using standard attributes. Please note that creating a rectangle using two points will re-calculate the start point to correspond with positive widths and heights.
Public methodRectangle(ViewBase, Point, Double, Double)
Creates a new rectangle instance with the start point and the defined width and height using standard attributes.
Public methodRectangle(ViewBase, Point, Point, RectangleRectangleAttributes)
Creates a new rectangle instance with two points using the given attributes. Please note that creating a rectangle using two points will re-calculate the start point to correspond with positive widths and heights.
Public methodRectangle(ViewBase, Point, Double, Double, RectangleRectangleAttributes)
Creates a new rectangle instance with the start point and the defined width and height using the given attributes.
Top
Properties
  NameDescription
Public propertyAngle
The angle of the rectangle. The rectangle rotates around its start point.
Public propertyAttributes
The attributes of the rectangle.
Public propertyEndPoint
The end point of the rectangle.
Public propertyHeight
The height of the rectangle. Changing the height changes the end point with the height.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
(Inherited from GraphicObject.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyStartPoint
The start point of the rectangle. Changing this will move the rectangle.
Public propertyWidth
The width of the rectangle. Changing the width changes the end point with the width.
Top
Methods
  NameDescription
Public methodDelete
Calls the system to delete the object.
(Overrides DatabaseObjectDelete.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Calls the system to insert the new object.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.)
Public methodSelect
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               Rectangle MyRectangle;
               DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
               while(views.MoveNext())
               {
                   MyRectangle = new Rectangle(views.Current as ViewBase, new Point(10,10), new Point(300,300));
                   MyRectangle.Insert();
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next