AnalysisModelGeneralProperties Class

The AnalysisModelGeneralProperties class contains the general property information for an analysis model.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisModelGeneralProperties

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisModelGeneralProperties

The AnalysisModelGeneralProperties type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModelGeneralProperties
Creates a new analysis model general properties instance.
Top
Properties
  NameDescription
Public propertyAnalysisEngineName
The name of the analysis engine.
Public propertyExtendedClashCheck
Defines whether the extended clash check is used.
Public propertyFilterName
The name of the filter.
Public propertyMemberAxisLocation
The location of the member axis.
Public propertyMemberEndReleaseMethodByConnection
Defines whether the support conditions of connections or parts are used.
Public propertyModalAnalysisModel
Defines whether the modal analysis properties are used instead of the static load combinations.
Public propertyModelCreationType
The model creation type.
Public propertyModelMerging
Defines whether the model merging is used.
Public propertyModelName
The name of the model.
Public propertyNodeDefinition
Defines how the nodes and node positions are defined.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next