IGeometryNodeVisitor Interface

The IGeometryNodeVisitor interface is implemented by classes visiting geometry nodes

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public interface IGeometryNodeVisitor
Methods
  NameDescription
Public methodVisit(SpiralNode)
Visits a node that is an instance of HelixNode
Public methodVisit(CylindricalSurfaceNode)
Visits a node that is an instance of CylindricalSurfaceNode
Public methodVisit(PolygonNode)
Visits a node that is an instance of PolygonNode node
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next