ViewCreateSectionView Method

Generates a new section view on the sheet and the associated section mark for the specified view.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static bool CreateSectionView(
	View view,
	Point startPoint,
	Point endPoint,
	Point viewInsertionPoint,
	double depthUp,
	double depthDown,
	ViewViewAttributes viewAttributes,
	SectionMarkBaseSectionMarkAttributes sectionMarkAttributes,
	out View sectionView,
	out SectionMark sectionMark
)

Parameters

view
Type: Tekla.Structures.DrawingView
The view in which to place the section mark.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The starting point of the section mark.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The ending point of the section mark.
viewInsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The point where to create the section view.
depthUp
Type: SystemDouble
The view depth up that the section view should cover.
depthDown
Type: SystemDouble
The view depth down that the section view should cover.
viewAttributes
Type: Tekla.Structures.DrawingViewViewAttributes
The attributes for the section view to be created.
sectionMarkAttributes
Type: Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
The attributes for the section mark to be created.
sectionView
Type: Tekla.Structures.DrawingView
The created section view is returned if the creation was successful. Otherwise, null is returned.
sectionMark
Type: Tekla.Structures.DrawingSectionMark
The created section mark is returned if the creation was successful. Otherwise, null is returned.

Return Value

Type: Boolean
True if the section view was created successfully.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next