GridLine Class

The GridLine class contains methods related to grid lines. A drawing grid line is always a child of a grid object.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridLine : ModelObject

The GridLine type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Public propertyEndLabel
The end of the grid line, contains the grid label and position information. For more information see GridLineGridLabel.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
(Inherited from ModelObject.)
Public propertyModelIdentifier
The database identifier of the model object in the model database. By using this identifier, it is possible to select the actual object in the Tekla Structures model.
(Inherited from ModelObject.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyStartLabel
The beginning of the grid line, contains the grid label and position information. For more information see GridLineGridLabel.
Top
Methods
  NameDescription
Public methodDelete
GridLines cannot be deleted.
(Overrides DatabaseObjectDelete.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
GridLines cannot be inserted.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.)
Public methodSelect
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Drawing MyDrawing = new GADrawing();
           View curview = new View(MyDrawing.GetSheet(), new CoordinateSystem(), new CoordinateSystem(),
               new AABB(new Point(), new Point(30000, 30000, 10000)));
           DrawingObjectEnumerator allObjects = curview.GetAllObjects();
           Grid curGrid = allObjects.Current as Grid;
           GridLine curGridLine;

           DrawingObjectEnumerator allGridLines = curGrid.GetObjects();
           while(allGridLines.MoveNext()) /* Iterate through all the grid lines of the grid */
           {
               if(allGridLines.Current is GridLine)
               {
                   curGridLine = allGridLines.Current as GridLine;
                   curGridLine.Attributes.DrawTextAtStartOfGridLine = true;
                   curGridLine.Attributes.DrawTextAtEndOfGridLine = true;
                   curGridLine.Attributes.Font.Color = DrawingColors.Red;

                   // The following code moves the grid labels off the grid lines by 200.
                   curGridLine.StartLabel.GridLabelPoint.Y = curGridLine.StartLabel.GridPoint.Y + 200;
                   curGridLine.EndLabel.GridLabelPoint.Y = curGridLine.EndLabel.GridPoint.Y + 200;

                   curGridLine.Modify(); /* Apply changes */
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next