GridLine Class

The GridLine class contains methods related to grid lines. A drawing grid line is always a child of a grid object.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridLine : ModelObject

The GridLine type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Public propertyEndLabel
The end of the grid line, contains the grid label and position information. For more information see GridLineGridLabel.
Public propertyStartLabel
The beginning of the grid line, contains the grid label and position information. For more information see GridLineGridLabel.
Top
Methods
  NameDescription
Public methodDelete
GridLines cannot be deleted.
(Overrides DatabaseObjectDelete.)
Public methodInsert
GridLines cannot be inserted.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.)
Public methodSelect
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.)
Top
Examples
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Drawing MyDrawing = new GADrawing();
           View curview = new View(MyDrawing.GetSheet(), new CoordinateSystem(), new CoordinateSystem(),
               new AABB(new Point(), new Point(30000, 30000, 10000)));
           DrawingObjectEnumerator allObjects = curview.GetAllObjects();
           Grid curGrid = allObjects.Current as Grid;
           GridLine curGridLine;

           DrawingObjectEnumerator allGridLines = curGrid.GetObjects();
           while(allGridLines.MoveNext()) /* Iterate through all the grid lines of the grid */
           {
               if(allGridLines.Current is GridLine)
               {
                   curGridLine = allGridLines.Current as GridLine;
                   curGridLine.Attributes.DrawTextAtStartOfGridLine = true;
                   curGridLine.Attributes.DrawTextAtEndOfGridLine = true;
                   curGridLine.Attributes.Font.Color = DrawingColors.Red;

                   // The following code moves the grid labels off the grid lines by 200.
                   curGridLine.StartLabel.GridLabelPoint.Y = curGridLine.StartLabel.GridPoint.Y + 200;
                   curGridLine.EndLabel.GridLabelPoint.Y = curGridLine.EndLabel.GridPoint.Y + 200;

                   curGridLine.Modify(); /* Apply changes */
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next