StraightDimensionSetHandlerCreateDimensionSet Method (ViewBase, PointList, Vector, Double)

Creates straight dimensions and combines them to one straight dimension set. Returns null if fails.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public StraightDimensionSet CreateDimensionSet(
	ViewBase View,
	PointList DimensionPoints,
	Vector UpDirection,
	double Distance
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view to be used.
DimensionPoints
Type: Tekla.Structures.DrawingPointList
The dimension points to be used.
UpDirection
Type: Tekla.Structures.Geometry3dVector
The direction from the dimension points to the dimension line.
Distance
Type: SystemDouble
The distance in paper millimeters taken from the first dimension point to the dimension line.

Return Value

Type: StraightDimensionSet
The created straight dimension set or null if fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next