AnalysisRigidDiaphragm Class

The AnalysisRigidDiaphragm class contains information related to analysis rigid diaphragms.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    Tekla.Structures.AnalysisAnalysisRigidDiaphragm

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisRigidDiaphragm : AnalysisObject

The AnalysisRigidDiaphragm type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisRigidDiaphragm
Initializes a new instance of the AnalysisRigidDiaphragm class
Top
Properties
  NameDescription
Public propertyExtremaMaximum
The maximum of the extrema (in the global coordinate system).
Public propertyExtremaMinimum
The minimum of the extrema (in the global coordinate system).
Public propertyMasterNodeID
The identifier of the master node.
Public propertyPartIDs
The part identifier.
Public propertySlaveNodeIDs
The slave node identifier.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next