PourBreakPourBreakAttributes Class

The PourBreakAttributes class is the attributes class for the pour break.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingPourBreakPourBreakAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class PourBreakAttributes : AttributesBase

The PourBreakPourBreakAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPourBreakPourBreakAttributes
Creates a new default pour break attributes instance that loads standard attributes.
Public methodPourBreakPourBreakAttributes(String)
Creates a new pour break attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyDrawHiddenLines
Indicates whether hidden lines are used to draw the pour break or not.
Public propertyHiddenLines
The hidden line type of the pour break.
Public propertyVisibleLines
The visible line type of the pour break.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next