AnalysisSubSection Class

The AnalysisSubSection class contains information related to analysis subsections.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisSubSection : AnalysisObject

The AnalysisSubSection type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisSubSection
Initializes a new instance of the AnalysisSubSection class
Top
Properties
  NameDescription
Public propertyB
The B value.
Public propertyB1
The B1 value.
Public propertyB2
The B2 value.
Public propertyB3
The B3 value.
Public propertyB4
The B4 value.
Public propertyH
The H value.
Public propertyH1
The H1 value.
Public propertyH2
The H2 value.
Public propertyIsHole
Defines whether the subsection is a hole.
Public propertyMaterial
The material of the subsection.
Public propertyOffsetAngle
The offset angle.
Public propertyOffsetY
The offset in the direction of the Y-axis.
Public propertyOffsetZ
The offset in the direction of the Z-axis.
Public propertyPoints
The points of the subsection.
Public propertyR1
The R1 value.
Public propertyR2
The R2 value.
Public propertySubType
The subtype of the subsection.
Public propertyT1
The T1 value.
Public propertyT2
The T2 value.
Public propertyT3
The T3 value.
Public propertyT4
The T4 value.
Public propertyTF
The TF value.
Public propertyTW
The TW value.
Public propertyType
The type of the subsection.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next