PluginCoordinateSystemAttribute Class

The PluginCoordinateSystemAttribute class is used for defining the coordinate system type for model plug-ins which are using points as an input. The attribute is initialized from the custom attribute [PluginCoordinateSystem(PluginBase.CoordinateSystemType Type)] in the plug-in source. If attribute is not defined or attribute has value PluginBase.CoordinateSystemType.FROM_FIRST_POINT_AND_GLOBAL coordinate system is calculated as earlier. The attribute is used if the first Inputdefinition object contains at least two points (defined by two points, line, face or polygon).
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsPluginCoordinateSystemAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class PluginCoordinateSystemAttribute : Attribute

The PluginCoordinateSystemAttribute type exposes the following members.

Constructors
  NameDescription
Public methodPluginCoordinateSystemAttribute(Int32)
The custom attribute used to define coordinate system of the plug-in. This is not to be used by itself.
Public methodPluginCoordinateSystemAttribute(PluginBaseCoordinateSystemType)
The custom attribute used to define coordinate system of the plug-in. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
Returns the type of the input object dependency.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next