MarkMarkAttributes Class

The MarkAttributes class defines the mark attributes.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class MarkAttributes : MarkBaseMarkBaseAttributes

The MarkMarkAttributes type exposes the following members.

Constructors
  NameDescription
Public methodMarkMarkAttributes(ModelObject)
Creates a new default mark attributes instance that loads standard attributes.
Public methodMarkMarkAttributes(ModelObject, String)
Creates a new mark attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyAngle
The actual angle of the mark, in degrees. Can differ from the rotation angle set by the user for marks, e.g. 45-degree column marks in GA drawings or when placing mark along part edges.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyArrowHead
The arrowhead of the leader line(s).
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyContent
The mark content as a list of elements.
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyFrame
The frame attributes of the mark's labels.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyPlacingAttributes
The placing attributes that the object should use. Using these you can specify whether the object is automatically arranged in the drawing or not.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyPreferredPlacing
The type of placing the object should use. See the preferred placing types for different types of placing.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyRotationAngle
The mark rotation angle set by the user. Unit is degrees.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyTextAlignment
The mark text alignment.
(Inherited from MarkBaseMarkBaseAttributes.)
Public propertyTransparentBackground
The mark text background transparency. (transparent/opaque)
(Inherited from MarkBaseMarkBaseAttributes.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next