OperationCreateMISFileFromSelected Method

Creates MIS files from the selected parts using the given file name.

See Tekla Structures Help for more information about MIS files.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool CreateMISFileFromSelected(
	OperationMISExportTypeEnum MISType,
	string FileName
)

Parameters

MISType
Type: Tekla.Structures.Model.OperationsOperationMISExportTypeEnum
The type of the MIS export.
FileName
Type: SystemString
The name of the MIS file to be used in creation.

Return Value

Type: Boolean
True if the MIS files are created, false if the numbering is not up-to-date or the used configuration is wrong.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the FileName is null.
ArgumentExceptionThrown when the FileName is not defined.
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Model.Operations;
using Tekla.Structures.Model.UI;

using System.Collections;
using System.Windows.Forms;

public class Example
{
       public void Example1()
       {
           Picker Picker = new Picker();

           try
           {
               Beam Beam1 = Picker.PickObject(Picker.PickObjectEnum.PICK_ONE_PART, "Pick object to Create MIS for") as Beam;
               ArrayList Parts = new ArrayList();

               Parts.Add(Beam1);
               Tekla.Structures.Model.UI.ModelObjectSelector MOS = new Tekla.Structures.Model.UI.ModelObjectSelector();

               MOS.Select(Parts);

               if (Operation.CreateMISFileFromSelected(Operation.MISExportTypeEnum.STEEL2000, "myExport.st2000"))
                   MessageBox.Show("MIS creation successful");

               MOS.Select(new ArrayList()); //remove UI selection
           }
           catch { }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next