GridGridAttributes Class

The GridAttributes class is the attributes class for the grid.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingGridGridAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridAttributes : AttributesBase

The GridGridAttributes type exposes the following members.

Constructors
  NameDescription
Public methodGridGridAttributes
Creates a new default grid attributes instance that loads standard attributes.
Public methodGridGridAttributes(String)
Creates a new grid attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyDrawOnlyTextLabelsNotGrids
Set as true if you don't want to draw the grids, only show the grids' text labels.
Public propertyDrawTextAtBottomOfGrid
Set as true if you want to show the grid's text labels at the bottom of the grid.
Public propertyDrawTextAtLeftOfGrid
Set as true if you want to show the grid's text labels at the left of the grid.
Public propertyDrawTextAtRightOfGrid
Set as true if you want to show the grid's text labels at the right of the grid.
Public propertyDrawTextAtTopOfGrid
Set as true if you want to show the grid's text labels at the top of the grid.
Public propertyFont
The grid's font attributes.
Public propertyFrame
The frame attributes of the grid's labels.
Public propertyLine
The grid's line attributes.
Public propertyOffsetAtEndOfLine
The offset for the end of the grid lines.
Public propertyOffsetAtStartOfLine
The offset for the beginning of the grid lines.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next