MarkBase Class

The MarkBase class contains general mark information and can be selected and modified with the general attributes.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class MarkBase : DrawingObject, 
	IObjectAlignedBoundingBox, IAxisAlignedBoundingBox, IMovableRelative, IPlacing, IHasChildren, 
	IHideable

The MarkBase type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the mark base attributes.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyInsertionPoint
The insertion point of the mark.
Public propertyIsAssociativeNote
Gets a value indicating whether the mark is an associative note.
Public propertyPlacing
The current placing of the object. See the placing types for different placing options.
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the instance from the database.
(Inherited from DatabaseObject.)
Public methodGetAxisAlignedBoundingBox
Returns the axis aligned bounding box of the text (rectangle format).
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetObjectAlignedBoundingBox
Returns the object aligned bounding box of the text (rectangle format).
Public methodGetObjects
Gets the children objects of the current object.
Public methodGetObjects(Type)
Gets the children objects of the current object that are of certain types.
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.)
Public methodIsEqual
Compares the current object with the given object. Checks every field of both objects for equality.
(Inherited from DrawingObject.)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the instance in the database.
(Inherited from DatabaseObject.)
Public methodMoveObjectRelative
Moves the object using the move vector.
Public methodSelect
Selects the object instance from the database.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
Examples
The following example enumerates through all marks in all views and changes their frame types to sharpened and their frame colors to red.
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               MarkBase MyMarkBase;
               DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
               while(views.MoveNext())
               {
                   DrawingObjectEnumerator allObjects = (views.Current as ViewBase).GetAllObjects();
                   while(allObjects.MoveNext())
                   {
                       if(allObjects.Current is MarkBase)
                       {
                           MyMarkBase = allObjects.Current as MarkBase;
                           MyMarkBase.Attributes.Frame.Color = DrawingColors.Red;
                           MyMarkBase.Attributes.Frame.Type = FrameTypes.Sharpened;
                           MyMarkBase.Modify();
                       }
                   }
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next