MarkBase Class

The MarkBase class contains general mark information and can be selected and modified with the general attributes.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class MarkBase : DrawingObject, 
	IObjectAlignedBoundingBox, IAxisAlignedBoundingBox, IMovableRelative, IPlacing, IHasChildren, 
	IHideable

The MarkBase type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the mark base attributes.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyInsertionPoint
The insertion point of the mark.
Public propertyIsAssociativeNote
Gets a value indicating whether the mark is an associative note.
Public propertyPlacing
The current placing of the object. See the placing types for different placing options.
Top
Methods
  NameDescription
Public methodGetAxisAlignedBoundingBox
Returns the axis aligned bounding box of the text (rectangle format).
Public methodGetObjectAlignedBoundingBox
Returns the object aligned bounding box of the text (rectangle format).
Public methodGetObjects
Gets the children objects of the current object.
Public methodGetObjects(Type)
Gets the children objects of the current object that are of certain types.
Public methodMoveObjectRelative
Moves the object using the move vector.
Top
Examples
The following example enumerates through all marks in all views and changes their frame types to sharpened and their frame colors to red.
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           DrawingHandler MyDrawingHandler = new DrawingHandler();
           if(MyDrawingHandler.GetConnectionStatus())
           {
               MarkBase MyMarkBase;
               DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews();
               while(views.MoveNext())
               {
                   DrawingObjectEnumerator allObjects = (views.Current as ViewBase).GetAllObjects();
                   while(allObjects.MoveNext())
                   {
                       if(allObjects.Current is MarkBase)
                       {
                           MyMarkBase = allObjects.Current as MarkBase;
                           MyMarkBase.Attributes.Frame.Color = DrawingColors.Red;
                           MyMarkBase.Attributes.Frame.Type = FrameTypes.Sharpened;
                           MyMarkBase.Modify();
                       }
                   }
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next