Analysis Class

The Analysis class is a class from which the user can query analysis instances.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysis

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Analysis

The Analysis type exposes the following members.

Constructors
  NameDescription
Public methodAnalysis
Initializes a new instance of the Analysis class.
Top
Methods
  NameDescription
Public methodGetAnalysisObjectSelector
Returns the analysis object selector.
Public methodGetConnectionStatus
Checks the connection status of the Tekla Structures process.
Top
Examples
using Tekla.Structures.Analysis;

public class Class
{
    public void Example()
    {
        Analysis Analysis = new Analysis();
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next