StraightDimension Class

The StraightDimension class defines straight dimensions.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class StraightDimension : DimensionBase

The StraightDimension type exposes the following members.

Constructors
  NameDescription
Public methodStraightDimension(ViewBase, Point, Point, Vector, Double)
Initializes a new instance of the StraightDimension class using "standard" attributes.
Public methodStraightDimension(ViewBase, Point, Point, Vector, Double, StraightDimensionSetStraightDimensionSetAttributes)
Initializes a new instance of the StraightDimension class.
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the dimension's attributes.
Public propertyDistance
Gets or sets the distance of the dimension line from the start point of the dimension.
Public propertyEndPoint
Gets or sets the end point of the dimension.
Public propertyStartPoint
Gets or sets the start point of the dimension.
Public propertyUpDirection
Gets or sets the direction from the dimension points to the dimension line.
Public propertyValue
Gets the content of the dimension mark.
Top
Methods
  NameDescription
Public methodDelete
Deletes the straight dimension from the database.
(Overrides DatabaseObjectDelete.)
Public methodGetDimensionSet
Gets the dimension set the current dimension belongs to.
(Overrides DimensionBaseGetDimensionSet.)
Public methodGetDimensionSet(Boolean)
Gets the dimension set the current dimension belongs to.
(Overrides DimensionBaseGetDimensionSet(Boolean).)
Public methodInsert
Inserts the straight dimension to the database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the existing straight dimension in the database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the straight dimension from the database.
(Overrides DatabaseObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next