StraightDimension Class

The StraightDimension class defines straight dimensions.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class StraightDimension : DimensionBase

The StraightDimension type exposes the following members.

Constructors
  NameDescription
Public methodStraightDimension(ViewBase, Point, Point, Vector, Double)
Initializes a new instance of the StraightDimension class using "standard" attributes.
Public methodStraightDimension(ViewBase, Point, Point, Vector, Double, StraightDimensionSetStraightDimensionSetAttributes)
Initializes a new instance of the StraightDimension class.
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the dimension's attributes.
Public propertyDistance
Gets or sets the distance of the dimension line from the start point of the dimension.
Public propertyEndPoint
Gets or sets the end point of the dimension.
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
(Inherited from DimensionBase.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertyStartPoint
Gets or sets the start point of the dimension.
Public propertyUpDirection
Gets or sets the direction from the dimension points to the dimension line.
Public propertyValue
Gets the content of the dimension mark.
Top
Methods
  NameDescription
Public methodDelete
Deletes the straight dimension from the database.
(Overrides DatabaseObjectDelete.)
Public methodGetDimensionSet
Gets the dimension set the current dimension belongs to.
(Overrides DimensionBaseGetDimensionSet.)
Public methodGetDimensionSet(Boolean)
Gets the dimension set the current dimension belongs to.
(Overrides DimensionBaseGetDimensionSet(Boolean).)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the straight dimension to the database.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the existing straight dimension in the database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the straight dimension from the database.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next