LinkFrameAttributes Class

The LinkFrameAttributes class contains the attributes for controlling the appearance of a link frame.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LinkFrameAttributes : GenericAttributesBase, 
	IAxisAlignedBoundingBox, IObjectAlignedBoundingBox, IIsEqual

The LinkFrameAttributes type exposes the following members.

Constructors
  NameDescription
Public methodLinkFrameAttributes
Initializes a new instance of the LinkFrameAttributes class
Top
Properties
  NameDescription
Public propertyColor Obsolete.
Public propertyLine
Gets or sets the line type.
Public propertyLineType Obsolete.
Top
Methods
  NameDescription
Public methodGetAxisAlignedBoundingBox
Gets the bounding box of the frame in the global axis coordinate system.
Public methodGetObjectAlignedBoundingBox
Gets the bounding box of the frame in the local coordinate system.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next