ComponentInputCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public void CopyTo(
	Array array,
	int index
)

Parameters

array
Type: SystemArray
The one-dimensional Array that is the destination of the elements copied from the ICollection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in the array at which copying begins.

Implements

ICollectionCopyTo(Array, Int32)
Exceptions
ExceptionCondition
ArgumentNullExceptionThe array is null.
ArgumentOutOfRangeExceptionThe index is less than zero.
ArgumentException The array is multidimensional, or the index is equal to or greater than the length of the array, or the number of elements in the source ICollection is greater than the available space from the index to the end of the destination array.
InvalidCastException The type of the source ICollection cannot be cast automatically to the type of the destination array.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next