Connection Class

The Connection class represents a connection. A connection is something that connects two or more parts together.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Connection : BaseComponent

The Connection type exposes the following members.

Constructors
  NameDescription
Public methodConnection
Creates a new connection instance.
Top
Properties
  NameDescription
Public propertyAutoDirectionType
The auto direction type. Default value is AUTODIR_BASIC. Value should be AUTODIR_NA to set direction with UpVector property. Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with connection attribute file.
Public propertyClass
The class of the connection.
Public propertyCode
The code of the connection. The code can be used to classify the connection. The code of the connection can be reported and shown in drawings. The maximum length of the string is 20 characters.
Public propertyPositionType
The position type.

When creating custom connections this attribute is not applied, instead the position type used when creating the custom connection is used.

Public propertyStatus
The read only status of the connection. The status can be reported and shown in drawings. The color of the connection symbol in the model indicates the status of the connection.
Public propertyUpVector
A vector indicating which direction is considered the up direction for the connection.
Top
Methods
  NameDescription
Public methodDelete
Deletes the connection instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodGetPrimaryObject
Returns the primary object of the connection.
Public methodGetSecondaryObjects
Returns the secondary objects.
Public methodInsert
Inserts the connection into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing connection in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a connection from the model database. The connection ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetPrimaryObject
Sets the primary object of the connection.
Public methodSetSecondaryObject
Sets the secondary object of the connection. Use this method if you wish to add only one secondary object to the connection.
Public methodSetSecondaryObjects
Sets an array list of model objects as the secondary objects of the connection.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using Tekla.Structures;
using System;

public class Example
{
       public void Example1()
       {
           Beam B1 = new Beam(new Point(15000,0,-500), new Point(15000,0,6000));
           B1.Profile.ProfileString = "HEA400";
           B1.Material.MaterialString = "S235JR";

           Beam B2 = new Beam(new Point(15000,0,0), new Point(18000,0,0));
           B2.Profile.ProfileString = "HEA400";
           B2.Material.MaterialString = "S235JR";

           B1.Insert();
           B2.Insert();

           Connection C = new Connection();
           C.Name = "Test End Plate";
           C.Number = 144;
           C.LoadAttributesFromFile("standard");
           C.UpVector = new Vector(0,0,1000);
           C.PositionType = PositionTypeEnum.COLLISION_PLANE;

           // Use this value to have the same orientation as defined in the attribute file 
           C.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_FROM_ATTRIBUTE_FILE;

           C.SetPrimaryObject(B1);
           C.SetSecondaryObject(B2);

           C.SetAttribute("e2", 10.0);
           C.SetAttribute("e1", 10.0);

           if(!C.Insert())
           {
               Console.WriteLine("Connection Insert failed");
           }
           else
           {
               Console.WriteLine(C.Identifier.ID);

               Double DValue = 0.0;
               if(!C.GetAttribute("e2", ref DValue) || DValue != 10)
                   Console.WriteLine("Connection GetAttribute failed");
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next