Connection Class

The Connection class represents a connection. A connection is something that connects two or more parts together.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Connection : BaseComponent

The Connection type exposes the following members.

Constructors
  NameDescription
Public methodConnection
Creates a new connection instance.
Top
Properties
  NameDescription
Public propertyAutoDirectionType
The auto direction type. Default value is AUTODIR_BASIC. Value should be AUTODIR_NA to set direction with UpVector property. Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with connection attribute file.
Public propertyClass
The class of the connection.
Public propertyCode
The code of the connection. The code can be used to classify the connection. The code of the connection can be reported and shown in drawings. The maximum length of the string is 20 characters.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
The name of the component. The name identifies custom components or plug-ins.
(Inherited from BaseComponent.)
Public propertyNumber
The number of the component. A number greater than zero identifies system components, for custom components the number is CUSTOM_OBJECT_NUMBER, and for plug-ins the number is PLUGIN_OBJECT_NUMBER.
(Inherited from BaseComponent.)
Public propertyPositionType
The position type.

When creating custom connections this attribute is not applied, instead the position type used when creating the custom connection is used.

Public propertyStatus
The read only status of the connection. The status can be reported and shown in drawings. The color of the connection symbol in the model indicates the status of the connection.
Public propertyUpVector
A vector indicating which direction is considered the up direction for the connection.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the connection instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAttribute(String, Double)
Retrieves the attribute with the given name.
(Inherited from BaseComponent.)
Public methodGetAttribute(String, Int32)
Retrieves the attribute with the given name.
(Inherited from BaseComponent.)
Public methodGetAttribute(String, String)
Retrieves the attribute with the given name.
(Inherited from BaseComponent.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetPrimaryObject
Returns the primary object of the connection.
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSecondaryObjects
Returns the secondary objects.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the connection into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodLoadAttributesFromFile
Loads the attributes for the component from the given file. These attributes will be loaded before all the attributes that have been set with the SetAttribute methods, so any attributes that are set with SetAttribute will override those loaded from the given standard file.
(Inherited from BaseComponent.)
Public methodModify
Modifies the existing connection in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a connection from the model database. The connection ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetAttribute(String, Double)
Sets the attribute's value to the given value.
(Inherited from BaseComponent.)
Public methodSetAttribute(String, Int32)
Sets the attribute's value to the given value.
(Inherited from BaseComponent.)
Public methodSetAttribute(String, String)
Sets the attribute's value to the given value.
(Inherited from BaseComponent.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetPrimaryObject
Sets the primary object of the connection.
Public methodSetSecondaryObject
Sets the secondary object of the connection. Use this method if you wish to add only one secondary object to the connection.
Public methodSetSecondaryObjects
Sets an array list of model objects as the secondary objects of the connection.
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using Tekla.Structures;
using System;

public class Example
{
       public void Example1()
       {
           Beam B1 = new Beam(new Point(15000,0,-500), new Point(15000,0,6000));
           B1.Profile.ProfileString = "HEA400";
           B1.Material.MaterialString = "S235JR";

           Beam B2 = new Beam(new Point(15000,0,0), new Point(18000,0,0));
           B2.Profile.ProfileString = "HEA400";
           B2.Material.MaterialString = "S235JR";

           B1.Insert();
           B2.Insert();

           Connection C = new Connection();
           C.Name = "Test End Plate";
           C.Number = 144;
           C.LoadAttributesFromFile("standard");
           C.UpVector = new Vector(0,0,1000);
           C.PositionType = PositionTypeEnum.COLLISION_PLANE;

           // Use this value to have the same orientation as defined in the attribute file 
           C.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_FROM_ATTRIBUTE_FILE;

           C.SetPrimaryObject(B1);
           C.SetSecondaryObject(B2);

           C.SetAttribute("e2", 10.0);
           C.SetAttribute("e1", 10.0);

           if(!C.Insert())
           {
               Console.WriteLine("Connection Insert failed");
           }
           else
           {
               Console.WriteLine(C.Identifier.ID);

               Double DValue = 0.0;
               if(!C.GetAttribute("e2", ref DValue) || DValue != 10)
                   Console.WriteLine("Connection GetAttribute failed");
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next