ModelObject Class

The ModelObject class is an abstract class for all model objects in the drawing side. The model objects of the drawing side contain identifiers of the actual model objects in the model database. The model objects appear and disappear based on current view properties (view size, settings).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class ModelObject : DrawingObject, 
	IHideable

The ModelObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes of the current object. Only attributes of the same type as the object are allowed.
(Inherited from DrawingObject.)
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyModelIdentifier
The database identifier of the model object in the model database. By using this identifier, it is possible to select the actual object in the Tekla Structures model.
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the instance from the database.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
(Inherited from DrawingObject.)
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
(Inherited from DrawingObject.)
Public methodInsert
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.)
Public methodIsEqual
Compares the current object with the given object. Checks every field of both objects for equality.
(Inherited from DrawingObject.)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the instance in the database.
(Inherited from DatabaseObject.)
Public methodSelect
Selects the object instance from the database.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.)
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingDatabaseObject
    Tekla.Structures.DrawingDrawingObject
      Tekla.Structures.DrawingModelObject
        Tekla.Structures.DrawingBolt
        Tekla.Structures.DrawingConnection
        Tekla.Structures.DrawingEdgeChamfer
        Tekla.Structures.DrawingGrid
        Tekla.Structures.DrawingGridLine
        Tekla.Structures.DrawingPart
        Tekla.Structures.DrawingPourBreak
        Tekla.Structures.DrawingPourObject
        Tekla.Structures.DrawingReferenceModel
        Tekla.Structures.DrawingReinforcementBase
        Tekla.Structures.DrawingSurfacing
        Tekla.Structures.DrawingWeld
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next