ModelObject Class

The ModelObject class is an abstract class for all model objects in the drawing side. The model objects of the drawing side contain identifiers of the actual model objects in the model database. The model objects appear and disappear based on current view properties (view size, settings).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class ModelObject : DrawingObject, 
	IHideable

The ModelObject type exposes the following members.

Properties
  NameDescription
Public propertyHideable
Accesses the information if this object is hidden or not or if it should be.
Public propertyModelIdentifier
The database identifier of the model object in the model database. By using this identifier, it is possible to select the actual object in the Tekla Structures model.
Top
Methods
  NameDescription
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingDatabaseObject
    Tekla.Structures.DrawingDrawingObject
      Tekla.Structures.DrawingModelObject
        Tekla.Structures.DrawingBolt
        Tekla.Structures.DrawingConnection
        Tekla.Structures.DrawingEdgeChamfer
        Tekla.Structures.DrawingGrid
        Tekla.Structures.DrawingGridLine
        Tekla.Structures.DrawingPart
        Tekla.Structures.DrawingPourBreak
        Tekla.Structures.DrawingPourObject
        Tekla.Structures.DrawingReferenceModel
        Tekla.Structures.DrawingReinforcementBase
        Tekla.Structures.DrawingSurfacing
        Tekla.Structures.DrawingWeld
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next