AnalysisPartAreaAttributes Class

The AnalysisPartAreaAttributes class contains information related to analysis part area attributes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisPartAreaAttributes

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisPartAreaAttributes

The AnalysisPartAreaAttributes type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisPartAreaAttributes
Initializes a new instance of the AnalysisPartAreaAttributes class
Top
Properties
  NameDescription
Public propertyAreaElementSizeHoles
Gets or sets the area element size holes.
Public propertyAreaElementSizeX
Gets or sets the area element size X.
Public propertyAreaElementSizeY
Gets or sets the area element size Y.
Public propertyAreaElementType
Gets or sets the area element type.
Public propertyAreaRotationXY
Gets or sets the area rotation XY.
Public propertyAreaStartNumber
Gets or sets the start number of the area.
Public propertyAreaSupport Obsolete.
Gets or sets the area support.
Public propertyAreaSupportType
Gets or sets the area support type.
Public propertyMinimumAreaHoleSize
Gets or sets the minimum area hole size.
Public propertyRigidDiaphragmFilterName
Gets or sets the filter name of the rigid diaphragm.
Public propertyUseSimpleArea
Gets or sets a value indicating whether simple areas are used.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next