ModelObjectModelObjectEnum Enumeration

All possible concrete model object subclasses are defined here. This enumeration can be used to fetch certain types of objects from the Tekla Structures model.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum ModelObjectEnum
Members
  Member nameValueDescription
UNKNOWN0 The unknown model object.
BEAM1 The beam.
POLYBEAM2 The polybeam.
CONTOURPLATE3 The contour plate.
BOOLEANPART4 The boolean part.
FITTING5 The fitting.
CUTPLANE6 The cutplane.
SURFACE_TREATMENT7 The surface treatment.
WELD8 The weld.
ASSEMBLY9 The assembly.
SINGLEREBAR10 The single rebar.
REBARGROUP11 The rebar group.
REBARMESH12 The rebar mesh.
REBARSTRAND13 The rebar strand.
CONTROL_PLANE14 The control plane.
BOLT_ARRAY15 The bolt array.
BOLT_CIRCLE16 The bolt circle.
BOLT_XYLIST17 The bolt XY list.
LOAD_POINT18 The point load.
LOAD_LINE19 The line load.
LOAD_AREA20 The area load.
LOAD_UNIFORM21 The uniform load.
GRID22 The grid.
GRIDPLANE23 The grid plane.
CONNECTION24 The connection.
COMPONENT25 The component.
SEAM26 The seam.
DETAIL27 The detail.
REFERENCE_MODEL28 The reference model.
REBAR_SPLICE29 The rebar splice.
LOAD_GROUP30 The load group.
TASK31 The task.
TASK_DEPENDENCY32 The task dependency.
TASK_WORKTYPE34 The task worktype.
POLYGON_WELD35 The polygon weld.
LOGICAL_WELD36 The logical weld.
CIRCLEREBAR37 The circle rebar.
HIERARCHIC_DEFINITION38 The hierarchic definition.
HIERARCHIC_OBJECT39 The hierarchic object.
ANALYSIS_GEOMETRY40 The analysis geometry.
ANALYSIS_PART41 The analysis part.
REFERENCE_MODEL_OBJECT42 The reference model object.
CUSTOM_PART43 The custom part object.
CIRCLE_REBARGROUP44 The circle rebar group.
CURVED_REBARGROUP45 The curved rebar group.
EDGE_CHAMFER46 The edge chamfer.
POUR_OBJECT47 The pour object.
POUR_BREAK48 The pour break.
CONTROL_LINE50 The control line.
LOAD_TEMPERATURE51 The temperature load.
BREP52 The Brep part instance.
CONTROL_CIRCLE53 The control circle.
CONTROL_POINT54 The control point.
REBAR_SET55 The rebar set.
REBAR_SET_ADDITION56 The rebar set addition.
REBAR_PROPERTY_MODIFIER57 The rebar property modifier.
REBAR_END_DETAIL_MODIFIER58 The rebar end-detail modifier.
REBAR_SPLITTER59 The rebar splitter.
CONTROL_ARC64 Construction arc.
CONTROL_SPLINE65 Construction spline
CONTROL_POLYCURVE66 Construction polycurve
RADIAL_GRID67 Radial grid
GRID_CYLINDRICAL_SURFACE68 Cylindrical surfaces of radial grids
LOFTED_PLATE69 The lofted plate
LEG_SURFACE_OBJECT70 The leg surface object.
STOREY71The storey object.
SPACE72The building space object.
BUILDING73The building space object.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next