AnalysisBar Class

The AnalysisBar class contains information related to analysis bars.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisBar : AnalysisObject

The AnalysisBar type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisBar
Initializes a new instance of the AnalysisBar class.
Top
Properties
  NameDescription
Public propertyAnalysisDesignCode
Gets or sets the analysis design code of the analysis bar.
Public propertyAnalysisType
Gets or sets the analysis type of the analysis bar.
Public propertyCardinalPoint
Gets or sets the cardinal point of the analysis bar.
Public propertyComposite
Gets or sets the composite beam of the analysis bar.
Public propertyCurvature
Gets or sets the curvature of the analysis bar.
Public propertyLabel
Gets or sets the label of the analysis bar.
Public propertyMaterial
Gets or sets the material of the analysis bar.
Public propertyMembers
Gets the members of the analysis bar.
Public propertyPositions
Gets the positions of the analysis bar.
Public propertyProfileEnd
Gets or sets the end profile of the analysis bar.
Public propertyProfileStart
Gets or sets the start profile of the analysis bar.
Top
Methods
  NameDescription
Public methodAdd(AnalysisPosition)
Adds a position to the analysis bar.
Public methodAdd(AnalysisPosition, AnalysisMember)
Adds a position and member to the analysis bar.
Public methodDelete
Deletes an analysis bar. The method is not implemented.
Public methodGetMembers
Gets the members of the analysis bar.
Public methodGetPositions
Gets the positions of the analysis bar.
Public methodModify
Modifies an analysis bar. The method is not implemented.
Public methodSelect
Selects an analysis bar. The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next