RebarItemExport Method

Exports the rebar item in the catlog to given file name. If path is not given rebar is exported to model folder. If filename is empty rebar name is used as filename.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool Export(
	ref string filename
)

Parameters

filename
Type: SystemString
The export file name of the item.

Return Value

Type: Boolean
True on success.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           RebarItem item = new RebarItem();

           if (item.Select("A500HW", "10", RebarItem.MAIN_USAGE))
           {
               string filename = System.IO.Path.GetTempPath() + "\\" + "A500HW_10_MAIN";
               if (item.Export(ref filename))
               {
                   Console.WriteLine("A500HW exported successfully");
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next