DrawingLink Constructor (ViewBase, Point, Drawing, String, Size, LinkAttributes)

Creates a new drawing link instance of the given size.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public DrawingLink(
	ViewBase View,
	Point InsertionPoint,
	Drawing Target,
	string Text,
	Size Size,
	LinkAttributes Attributes
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
A drawing view.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location for the link.
Target
Type: Tekla.Structures.DrawingDrawing
The link target.
Text
Type: SystemString
The link text visible to the user.
Size
Type: Tekla.Structures.DrawingSize
The width and height for the link.
Attributes
Type: Tekla.Structures.DrawingLinkAttributes
The attributes for creating the link.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next