BaseComponent Class

The BaseComponent class is an abstract base class that represents generic components. The generic components derived from the base component are the component, the connection, the detail and the seam.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class BaseComponent : ModelObject

The BaseComponent type exposes the following members.

Constructors
  NameDescription
Public methodBaseComponent
Creates a base component instance with default attributes.
Top
Properties
  NameDescription
Public propertyName
The name of the component. The name identifies custom components or plug-ins.
Public propertyNumber
The number of the component. A number greater than zero identifies system components, for custom components the number is CUSTOM_OBJECT_NUMBER, and for plug-ins the number is PLUGIN_OBJECT_NUMBER.
Top
Methods
  NameDescription
Public methodGetAttribute(String, Double)
Retrieves the attribute with the given name.
Public methodGetAttribute(String, Int32)
Retrieves the attribute with the given name.
Public methodGetAttribute(String, String)
Retrieves the attribute with the given name.
Public methodLoadAttributesFromFile
Loads the attributes for the component from the given file. These attributes will be loaded before all the attributes that have been set with the SetAttribute methods, so any attributes that are set with SetAttribute will override those loaded from the given standard file.
Public methodSetAttribute(String, Double)
Sets the attribute's value to the given value.
Public methodSetAttribute(String, Int32)
Sets the attribute's value to the given value.
Public methodSetAttribute(String, String)
Sets the attribute's value to the given value.
Top
Fields
  NameDescription
Public fieldStatic memberClassFromAttributeFile
A constant integer defining that the class is to be read from the attribute file. The class must be set to this constant value before inserting the component.
Public fieldStatic memberConnectionCodeFromAttributeFile
A constant string defining that the connection code is to be read from the attribute file. The connection code must be set to this constant value before inserting the component.
Public fieldStatic memberCUSTOM_OBJECT_NUMBER
The component number to be used when calling a custom component.
Public fieldStatic memberPLUGIN_OBJECT_NUMBER
The component number to be used when calling a plug-in or a type derived from the connection base.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next