AnalysisRestraintData Class

The AnalysisRestraintData class contains the restraint data for an analysis part.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisRestraintData

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisRestraintData

The AnalysisRestraintData type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisRestraintData
Creates a new instance of an analysis restraint data.
Top
Properties
  NameDescription
Public propertyLocalCoordinateSystem
The local coordinate system.
Public propertyReleaseType
The release type.
Public propertyRxSpring
The rotation in the X-axis direction (Nmm/rad).
Public propertyRxType
The restraint type for the rotation in the X-axis direction.
Public propertyRySpring
The rotation in the Y-axis direction (Nmm/rad).
Public propertyRyType
The restraint type for the rotation in the Y-axis direction.
Public propertyRzSpring
The rotation in the Z-axis direction (Nmm/rad).
Public propertyRzType
The restraint type for the rotation in the Z-axis direction.
Public propertySupported
The support condition.
Public propertyUxSpring
The displacement in the X-axis direction (N/mm).
Public propertyUxType
The restraint type for the displacement in the X-axis direction.
Public propertyUySpring
The displacement in the Y-axis direction (N/mm).
Public propertyUyType
The restraint type for the displacement in the Y-axis direction.
Public propertyUzSpring
The displacement in the Z-axis direction (N/mm).
Public propertyUzType
The restraint type for the displacement in the Z-axis direction.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next