CylindricalSurface Constructor (Arc, Double)

Initializes a new instance of the CylindricalSurface class from a base arc and a height. This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public CylindricalSurface(
	Arc baseArc,
	double height
)

Parameters

baseArc
Type: Tekla.Structures.Geometry3dArc
Arc to form the base of the bend surface
height
Type: SystemDouble
Height of the surface measured along the normal of the arc, may be positive or negative, but always nonzero
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the given lengths are invalid
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next