MateriaClientAdapterLoadGraph Method (Asset, ListGraphParameter)

Loads the graph corresponding to the specified uri providing the explicit parameter values and retrieves it's GUID

Namespace:  Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public Task<IGraph> LoadGraph(
	Asset asset,
	List<GraphParameter> graphParameters
)

Parameters

asset
Type: Tekla.Structures.TeklaStructuresInternal.MateriaClientAsset
graphParameters
Type: System.Collections.GenericListGraphParameter
The list of parameters

Return Value

Type: TaskIGraph
The GUID of the loaded graph as a string, or empty string if the graph loading didn't succeed.

Implements

IMateriaClientAdapterLoadGraph(Asset, ListGraphParameter)
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next