CurvedDimensionSetHandler Class

The CurvedDimensionSetHandler class contains operations for creating curved dimension sets.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingCurvedDimensionSetHandler

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class CurvedDimensionSetHandler

The CurvedDimensionSetHandler type exposes the following members.

Constructors
  NameDescription
Public methodCurvedDimensionSetHandler
Initializes a new instance of the CurvedDimensionSetHandler class
Top
Methods
  NameDescription
Public methodCreateCurvedDimensionSetOrthogonal(ViewBase, Point, Point, Point, PointList, Double)
Creates a curved dimension set with orthogonal reference lines from the specified points and inserts it to the database.
Public methodCreateCurvedDimensionSetOrthogonal(ViewBase, Point, Point, Point, PointList, Double, CurvedDimensionSetOrthogonalCurvedDimensionSetOrthogonalAttributes)
Creates a curved dimension set with orthogonal reference lines from the specified points and inserts it to the database.
Public methodCreateCurvedDimensionSetRadial(ViewBase, Point, Point, Point, PointList, Double)
Creates a curved dimension set from the specified points and inserts it to the database. Uses the default attributes.
Public methodCreateCurvedDimensionSetRadial(ViewBase, Point, Point, Point, PointList, Double, CurvedDimensionSetRadialCurvedDimensionSetRadialAttributes)
Creates a curved dimension set from the specified points and inserts it to the database.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next