RadialGrid Class

The RadialGrid class defines a user defined (possibly magnetic) set; radial grid has grid planes and cylindrical grid planes as children
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RadialGrid : GridBase

The RadialGrid type exposes the following members.

Constructors
  NameDescription
Public methodRadialGrid
Creates a new radial grid instance. Overrides the default creation parameters by forcing the angular coordinates to be "0.0 6*15.0"
Top
Properties
  NameDescription
Public propertyAngularCoordinates
The angular coordinates of the grid lines
Public propertyAngularLabels
The labels for the angular grid lines.
Public propertyAngularLinesEndExtension
The extension of the angular grid lines at their end point.
Public propertyAngularLinesStartExtension
The extension of the angular grid lines at their start point.
Public propertyArcEndExtension
The extension of the grid arcs at their end point.
Public propertyArcStartExtension
The extension of the grid arcs at their start point.
Public propertyColor
Gets or sets the color of the grid.
Public propertyCoordinateZ
The coordinates for the Z-axis.
Public propertyExtensionAboveZ
The extension above Z-axis.
Public propertyExtensionBelowZ
The extension below the Z-axis.
Public propertyFontColor
Gets or sets font color for the grid labels
(Inherited from GridBase.)
Public propertyFontSize
Gets or sets font size for the grid labels
(Inherited from GridBase.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsMagnetic
Gets or sets whether the grid is magnetic or not
(Overrides GridBaseIsMagnetic.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLabelZ
The labels for the Z-axis.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the grid.
(Inherited from GridBase.)
Public propertyOrigin
Gets or sets the origin of the grid
(Inherited from GridBase.)
Public propertyRadialCoordinates
The distances between the radii of the arcs
Public propertyRadialLabels
The labels for the grid arcs.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the grid with the given ID.
(Inherited from GridBase.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the grid into the model.
(Inherited from GridBase.)
Public methodModify
Modifies the grid with the given ID.
(Inherited from GridBase.)
Public methodSelect
Selects the grid with the given ID.
(Inherited from GridBase.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           RadialGrid grid = new RadialGrid();
           grid.IsMagnetic = true;
           bool Result = Grid.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next