RadialGrid Class

The RadialGrid class defines a user defined (possibly magnetic) set; radial grid has grid planes and cylindrical grid planes as children
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RadialGrid : GridBase

The RadialGrid type exposes the following members.

Constructors
  NameDescription
Public methodRadialGrid
Creates a new radial grid instance. Overrides the default creation parameters by forcing the angular coordinates to be "0.0 6*15.0"
Top
Properties
  NameDescription
Public propertyAngularCoordinates
The angular coordinates of the grid lines
Public propertyAngularLabels
The labels for the angular grid lines.
Public propertyAngularLinesEndExtension
The extension of the angular grid lines at their end point.
Public propertyAngularLinesStartExtension
The extension of the angular grid lines at their start point.
Public propertyArcEndExtension
The extension of the grid arcs at their end point.
Public propertyArcStartExtension
The extension of the grid arcs at their start point.
Public propertyColor
Gets or sets the color of the grid.
Public propertyCoordinateZ
The coordinates for the Z-axis.
Public propertyExtensionAboveZ
The extension above Z-axis.
Public propertyExtensionBelowZ
The extension below the Z-axis.
Public propertyIsMagnetic
Gets or sets whether the grid is magnetic or not
(Overrides GridBaseIsMagnetic.)
Public propertyLabelZ
The labels for the Z-axis.
Public propertyRadialCoordinates
The distances between the radii of the arcs
Public propertyRadialLabels
The labels for the grid arcs.
Top
Methods
  NameDescription
Top
Examples
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           RadialGrid grid = new RadialGrid();
           grid.IsMagnetic = true;
           bool Result = Grid.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next