RebarGuideline Class

Defines a rebar guideline that is used in a RebarSet. A RebarSet has a minimum of one rebar guideline, the primary guideline.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarGuideline

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarGuideline

The RebarGuideline type exposes the following members.

Constructors
  NameDescription
Public methodRebarGuideline
Initializes a new instance of the RebarGuideline class.
Top
Properties
  NameDescription
Public propertyCurve
Gets or sets the geometric Contour of the rebar guideline.
Public propertyFollowEdges
Gets or sets a flag that indicates whether the guideline should attempt to follow the leg face edges located between its end points.
Public propertyId
Gets or sets an identifier that may be used to identify instances of the same rebar guideline.
Public propertySpacing
Gets or sets the RebarSpacing along the rebar guideline.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next