PlacingTypes Class

The PlacingTypes class defines the different available placing types. Please note that not all objects accept all types. If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPlacingTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static class PlacingTypes

The PlacingTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAlongLinePlacing
The object is located and moved along a line defined by two points.
Public methodStatic memberBaseLinePlacing
The object is placed using a line as a reference. This will thus define the object's X-axis along that line.
Public methodStatic memberLeaderLinePlacing
The object is placed attached to a leader line.
Public methodStatic memberPointPlacing
The object is placed at one point (the insertion point) without any additional placing options.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next