AABBAddition Operator (AABB, Point)

Adds the given point to the given axis-aligned 3d bounding box.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static AABB operator +(
	AABB AABB,
	Point Point
)

Parameters

AABB
Type: Tekla.Structures.Geometry3dAABB
The axis-aligned 3d bounding box to add to.
Point
Type: Tekla.Structures.Geometry3dPoint
The point to be added.

Return Value

Type: AABB
The new axis-aligned 3d bounding box which includes the given axis-aligned 3d bounding box and the given point.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next