SectionMarkBaseSectionMarkTagAttributes Class

The SectionMarkTagAttributes class contains attributes for section mark tags.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingViewMarkBasicTagAttributes
      Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SectionMarkTagAttributes : ViewMarkBasicTagAttributes

The SectionMarkBaseSectionMarkTagAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyLocation
The location of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.)
Public propertyOffset
The offset of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.)
Public propertyShowOnSide
The side(s) on which the tag is shown.
Public propertyTagContent
The tag content.
(Inherited from ViewMarkBasicTagAttributes.)
Public propertyTagRotation
The policy for the tag rotation.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides ViewMarkBasicTagAttributesIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next