Tekla.Structures.Datatype Namespace

The Tekla.Structures.Datatype namespace contains methods related to different datatypes.
Classes
  ClassDescription
Public classAngle
Provides support for angles using either the current Tekla Structures units, or user defined units
Public classAngleList
This class provides methods to handle lists of angles
Public classBooleanConverter
The BooleanConverter class converts types to and from the boolean type.
Public classConstants
The Constants class is a repository for constants used by the Tekla.Structures.Datatype.* types.
Public classDistanceConverter
The DistanceConverter class converts types to and from the distance type.
Public classDistanceListConverter
The DistanceListConverter class converts types to and from the distance list type.
Public classDoubleConverter
The DoubleConverter class converts types to and from the double datatype.
Public classEnumConverter
Type converter for Enum
Public classIntegerConverter
The IntegerConverter class converts types to and from the integer datatype.
Public classSettings
The Settings class contains the currently active unit settings.
Public classSettingsProxy
The SettingsProxy class is a proxy for the settings.
Public classStringConverter
The StringConverter class converts types to and from the string datatype.
Structures
  StructureDescription
Public structureBoolean
The Boolean datatype.
Public structureCode exampleDistance
The Distance datatype.
Public structureDistanceList
A list of Distance instances.
Public structureDouble
The Double datatype.
Public structureEnumE
The Enum datatype generic.
Public structureInteger
The Integer datatype.
Public structureString
The String datatype.
Interfaces
  InterfaceDescription
Public interfaceIDataType
The IDataType interface is the root interface for converting all the Tekla.Structures.Datatype.* types to basic types supported by the Tekla Structures Object Dialog tree.
Public interfaceIDoubleDataType
The IDoubleDataType interface is an interface for the Tekla.Structures.Datatype.* types whose value is a double.
Public interfaceIIntDataType
The IIntDataType interface is an interface for the Tekla.Structures.Datatype.* types whose value is an integer.
Public interfaceIStringDataType
The IStringDataType interface is an interface for the Tekla.Structures.Datatype.* types whose value is a string.
Enumerations
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next