PluginSymbolVisiblityAttribute Class

The PluginSymbolVisiblityAttribute class is used for defining the symbol visibility for model plug-ins. The attribute is initialized from the custom attribute [PluginSymbolVisiblity(PluginBase.SymbolVisibility Type)] in the plug-in source. If attribute is not defined or attribute has value PluginBase.SymbolVisibility.DRAW_SYMBOL plug-in symbol is drawn normally.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsPluginSymbolVisiblityAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class PluginSymbolVisiblityAttribute : Attribute

The PluginSymbolVisiblityAttribute type exposes the following members.

Constructors
  NameDescription
Public methodPluginSymbolVisiblityAttribute(Int32)
The custom attribute used to define coordinate system of the plug-in. This is not to be used by itself.
Public methodPluginSymbolVisiblityAttribute(PluginBaseSymbolVisibility)
The custom attribute used to define coordinate system of the plug-in. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
Returns the type of the input object dependency.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next