AnalysisLoadCombination Class

The AnalysisLoadCombination class contains information related to analysis load combinations.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    Tekla.Structures.AnalysisAnalysisLoadCombination

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisLoadCombination : AnalysisObject

The AnalysisLoadCombination type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisLoadCombination
Initializes a new instance of the AnalysisLoadCombination class.
Top
Properties
  NameDescription
Public propertyGroupIDs
Gets or sets the identifiers of the groups of the analysis load combination.
Public propertyName
Gets or sets the name of the analysis load combination.
Public propertyPartialSafetyFactors
Gets or sets the partial safety factors of the analysis load combination.
Public propertyReductionFactors
Gets or sets the reduction factors of the analysis load combination.
Public propertyScalingFactors
Gets or sets the scaling factors of the analysis load combination.
Public propertyType
Gets or sets the combination type of the analysis load combination.
Top
Methods
  NameDescription
Public methodDelete
Deletes an analysis load combination. The AnalysisModelName and ID have to be set.
Public methodInsert
Inserts an analysis load combination. The AnalysisModelName has to be set.
Public methodModify
Modifies an analysis load combination. The AnalysisModelName and ID have to be set.
Public methodSelect
Selects an analysis load combination. The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.)
Public methodSetLoads
Sets the loads.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next