Tekla.Structures.Filtering.Categories Namespace

The Tekla.Structures.Filtering.Categories namespace includes all the necessary Tekla Structures filter categories for creating the filter files.
Classes
  ClassDescription
Public classAssemblyFilterExpressions
The AssemblyFilterExpressions class contains all the assembly filter expressions.
Public classAssemblyFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classAssemblyFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classAssemblyFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classAssemblyFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classAssemblyFilterExpressionsGuid
The Guid class represents the GUID filter expression.
Public classAssemblyFilterExpressionsIdNumber
The IdNumber class represents the identifier number filter expression.
Public classAssemblyFilterExpressionsLevel
The Level class represents the level filter expression.
Public classAssemblyFilterExpressionsName
The Name class represents the name filter expression.
Public classAssemblyFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classAssemblyFilterExpressionsPositionNumber
The PositionNumber class represents the position number filter expression.
Public classAssemblyFilterExpressionsPrefix
The Prefix class represents the prefix filter expression.
Public classAssemblyFilterExpressionsSeries
The Series class represents the series filter expression.
Public classAssemblyFilterExpressionsStartNumber
The StartNumber class represents the start number filter expression.
Public classAssemblyFilterExpressionsType
The Type class represents the type filter expression.
Public classBoltFilterExpressions
The BoltFilterExpressions class contains all the bolt filter expressions.
Public classBoltFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classBoltFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classBoltFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classBoltFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classBoltFilterExpressionsLength
The Length class represents the length filter expression.
Public classBoltFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classBoltFilterExpressionsSiteWorkshop
The SiteWorkshop class represents the site/workshop filter expression.
Public classBoltFilterExpressionsSize
The Size class represents the size filter expression.
Public classBoltFilterExpressionsStandard
The Standard class represents the standard filter expression.
Public classComponentFilterExpressions
The ComponentFilterExpressions class contains all the component filter expressions.
Public classComponentFilterExpressionsConnectionCode
The ConnectionCode class represents the connection code filter expression.
Public classComponentFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classComponentFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classComponentFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classComponentFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classComponentFilterExpressionsName
The Name class represents the name filter expression.
Public classComponentFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classComponentFilterExpressionsRunningNumber
The RunningNumber class represents the running number filter expression.
Public classConstructionObjectFilterExpressions
The ConstructionObjectFilterExpressions class contains all the construction object filter expressions.
Public classConstructionObjectFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classConstructionObjectFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classConstructionObjectFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classConstructionObjectFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classConstructionObjectFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classConstructionObjectFilterExpressionsType
The Type class represents the type filter expression.
Public classLoadFilterExpressions
The LoadFilterExpressions class contains all the load filter expressions.
Public classLoadFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classLoadFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classLoadFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classLoadFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classLoadFilterExpressionsGroup
The Group class represents the group filter expression.
Public classLoadFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classLoadFilterExpressionsType
The Type class represents the type filter expression.
Public classLogicalAreaFilterExpressions
The LogicalAreaFilterExpressions class contains all the logical area filter expressions.
Public classLogicalAreaFilterExpressionsBuilding
The Building class represents the building filter expression.
Public classLogicalAreaFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classLogicalAreaFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classLogicalAreaFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classLogicalAreaFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classLogicalAreaFilterExpressionsSection
The Section class represents the section filter expression.
Public classLogicalAreaFilterExpressionsSite
The Site class represents the site filter expression.
Public classLogicalAreaFilterExpressionsStory
The Story class represents the story filter expression.
Public classObjectFilterExpressions
The ObjectFilterExpressions class contains all the object filter expressions.
Public classObjectFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classObjectFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classObjectFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classObjectFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classObjectFilterExpressionsGuid
The Guid class represents the GUID filter expression.
Public classObjectFilterExpressionsIdNumber
The IdNumber class represents the identifier number filter expression.
Public classObjectFilterExpressionsIsComponent
The IsComponent class represents the "is component" filter expression.
Public classObjectFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classObjectFilterExpressionsType
The Type class represents the type filter expression.
Public classObjectTypesFilterExpressions
The ObjectTypesFilterExpressions class contains all the object type filter expressions.
Public classObjectTypesFilterExpressionsCategoryName
The CategoryName class represents the category name filter expression.
Public classObjectTypesFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classObjectTypesFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classObjectTypesFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classObjectTypesFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classObjectTypesFilterExpressionsEntityName
The EntityName class represents the entity name filter expression.
Public classPartFilterExpressions
The PartFilterExpressions class contains all the part filter expressions.
Public classPartFilterExpressionsClass
The Class class represents the class filter expression.
Public classPartFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classPartFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classPartFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classPartFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classPartFilterExpressionsFinish
The Finish class represents the finish filter expression.
Public classPartFilterExpressionsLot
The Lot class represents the lot filter expression.
Public classPartFilterExpressionsMaterial
The Material class represents the material filter expression.
Public classPartFilterExpressionsName
The Name class represents the name filter expression.
Public classPartFilterExpressionsNumberingSeries
The NumberingSeries class represents the numbering series filter expression.
Public classPartFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classPartFilterExpressionsPositionNumber
The PositionNumber class represents the position number filter expression.
Public classPartFilterExpressionsPourPhase
The PourPhase class represents the pour phase filter expression.
Public classPartFilterExpressionsPrefix
The Prefix class represents the prefix filter expression.
Public classPartFilterExpressionsPrimaryPart
The PrimaryPart class represents the primary part filter expression.
Public classPartFilterExpressionsProfile
The Profile class represents the profile filter expression.
Public classPartFilterExpressionsStartNumber
The StartNumber class represents the start number filter expression.
Public classPourBreakFilterExpressions
The PourBreakFilterExpressions class contains all the pour break filter expressions.
Public classPourBreakFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classPourBreakFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classPourBreakFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classPourBreakFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classPourObjectFilterExpressions
The PourObjectFilterExpressions class contains all the pour object filter expressions.
Public classPourObjectFilterExpressionsConcreteMixture
The ConcreteMixture class represents the concrete mixture filter expression.
Public classPourObjectFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classPourObjectFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classPourObjectFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classPourObjectFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classPourObjectFilterExpressionsMaterial
The Material class represents the material filter expression.
Public classPourObjectFilterExpressionsPourNumber
The PourNumber class represents the pour number filter expression.
Public classPourObjectFilterExpressionsPourPhase
The PourPhase class represents the pour phase filter expression.
Public classPourObjectFilterExpressionsPourType
The PourType class represents the pour type filter expression.
Public classPourUnitFilterExpressions
The PourUnitFilterExpressions class contains all the pour unit filter expressions.
Public classPourUnitFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classPourUnitFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classPourUnitFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classPourUnitFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classPourUnitFilterExpressionsGuid
The Guid class represents the GUID filter expression.
Public classPourUnitFilterExpressionsName
The Name class represents the name filter expression.
Public classReferenceObjectFilterExpressions
The ReferenceObjectFilterExpressions class contains all the reference object filter expressions.
Public classReferenceObjectFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classReferenceObjectFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classReferenceObjectFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classReferenceObjectFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classReinforcingBarFilterExpressions
The ReinforcingBarFilterExpressions class contains all the reinforcing bar filter expressions.
Public classReinforcingBarFilterExpressionsClass
The Class class represents the class filter expression.
Public classReinforcingBarFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classReinforcingBarFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classReinforcingBarFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classReinforcingBarFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classReinforcingBarFilterExpressionsDiameter
The Diameter class represents the diameter filter expression.
Public classReinforcingBarFilterExpressionsJoinType
The JoinType class represents the join type filter expression.
Public classReinforcingBarFilterExpressionsLength
The Length class represents the length filter expression.
Public classReinforcingBarFilterExpressionsMaterial
The Material class represents the material filter expression.
Public classReinforcingBarFilterExpressionsName
The Name class represents the name filter expression.
Public classReinforcingBarFilterExpressionsNumberingSeries
The NumberingSeries class represents the numbering series filter expression.
Public classReinforcingBarFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classReinforcingBarFilterExpressionsPosition
The Position class represents the position filter expression.
Public classReinforcingBarFilterExpressionsPositionNumber
The PositionNumber class represents the position number filter expression.
Public classReinforcingBarFilterExpressionsPrefix
The Prefix class represents the prefix filter expression.
Public classReinforcingBarFilterExpressionsShape
The Shape class represents the shape filter expression.
Public classReinforcingBarFilterExpressionsSize
The Size class represents the size filter expression.
Public classReinforcingBarFilterExpressionsStartNumber
The StartNumber class represents the start number filter expression.
Public classSurfaceFilterExpressions
The SurfaceFilterExpressions class contains all the surface object filter expressions.
Public classSurfaceFilterExpressionsClass
The Class class represents the class filter expression.
Public classSurfaceFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classSurfaceFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classSurfaceFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classSurfaceFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classSurfaceFilterExpressionsName
The Name class represents the name filter expression.
Public classSurfaceFilterExpressionsType
The Type class represents the type filter expression.
Public classTaskFilterExpressions
The TaskFilterExpressions class contains all the task filter expressions.
Public classTaskFilterExpressionsActualEndDate
The ActualEndDate class represents the actual end date filter expression.
Public classTaskFilterExpressionsActualStartDate
The ActualStartDate class represents the actual start date filter expression.
Public classTaskFilterExpressionsCompleteness
The Completeness class represents the completeness filter expression.
Public classTaskFilterExpressionsCritical
The Critical class represents the critical filter expression.
Public classTaskFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classTaskFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classTaskFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classTaskFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classTaskFilterExpressionsLocal
The Local class represents the local filter expression.
Public classTaskFilterExpressionsName
The Name class represents the name filter expression.
Public classTaskFilterExpressionsPlannedEndDate
The PlannedEndDate class represents the planned end date filter expression.
Public classTaskFilterExpressionsPlannedStartDate
The PlannedStartDate class represents the planned start date filter expression.
Public classTemplateFilterExpressions
The TemplateFilterExpressions class contains all the template filter expressions.
Public classTemplateFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classTemplateFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classTemplateFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classTemplateFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classWeldFilterExpressions
The WeldFilterExpressions class contains all the weld filter expressions.
Public classWeldFilterExpressionsCustomBoolean
The CustomBoolean class represents a custom Boolean filter expression.
Public classWeldFilterExpressionsCustomDateTime
The CustomDateTime class represents a custom DateTime filter expression.
Public classWeldFilterExpressionsCustomNumber
The CustomNumber class represents a custom numeric filter expression.
Public classWeldFilterExpressionsCustomString
The CustomString class represents a custom string filter expression.
Public classWeldFilterExpressionsPhase
The Phase class represents the phase filter expression.
Public classWeldFilterExpressionsPositionNumber
The PositionNumber class represents the position number filter expression.
Public classWeldFilterExpressionsReferenceText
The ReferenceText class represents the reference text filter expression.
Public classWeldFilterExpressionsSizeAboveLine
The SizeAboveLine class represents the size above line filter expression.
Public classWeldFilterExpressionsSizeBelowLine
The SizeBelowLine class represents the size below line filter expression.
Public classWeldFilterExpressionsTypeAboveLine
The TypeAboveLine class represents the type above line filter expression.
Public classWeldFilterExpressionsTypeBelowLine
The TypeBelowLine class represents the type below line filter expression.
Public classWeldFilterExpressionsWeldingSite
The WeldingSite class represents the welding site filter expression.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next