BentPlateGeometrySolverModifyRadius Method

Modify the radius of a cylindrical section.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry ModifyRadius(
	ConnectiveGeometry geometry,
	GeometrySection cylindricalSection,
	double radius
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains cylindricalSection.
cylindricalSection
Type: Tekla.Structures.ModelGeometrySection
The cylindrical geometry section to modify.
radius
Type: SystemDouble
The new radius for the cylindrical section.

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not modify radius.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next