ShapeItemSetHandlePoints Method

Set the Shape item's Handle Points

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool SetHandlePoints(
	List<Point> HandlePoints
)

Parameters

HandlePoints
Type: System.Collections.GenericListPoint
The handle points.

Return Value

Type: Boolean
True if success or False
Examples
public void SetHandlePointsTest()
{

    var polymesh = CreateSomeValidBrep();
    var shapeItem = new ShapeItem
    {
        Name = "TestFileName",
        ShapeFacetedBrep = polymesh,
        UpAxis = ShapeUpAxis.Z_Axis
    };

    shapeItem.Insert();

    var handlePoints = new List<Point>;
        {
          new Point(100.0, 100.0, 100.0),
          new Point(-100.0, -100.0, -100.0),
        };

   shapeItem.SetHandlePoints(handlePoints);
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next