AnalysisObjectSelector Class

The AnalysisObjectSelector class contains methods for getting objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObjectSelector

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisObjectSelector

The AnalysisObjectSelector type exposes the following members.

Methods
  NameDescription
Public methodGetAllObjects
Returns an enumerator of all the model objects in the current model. NOT YET IMPLEMENTED.
Public methodGetAllObjectsWithType
Returns an enumerator of all the model objects in the current model with the given type.
Public methodGetAnalysisModels
Returns an enumerator of all the analysis model objects.
Public methodGetSelectedObjects
Returns an enumerator of all the selected model objects in the current model. NOT YET IMPLEMENTED.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next