BentPlateGeometrySolverModifyBendSurface Method

Modifies the shape of a bend surface section, and updates related polygon sections accordingly.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry ModifyBendSurface(
	ConnectiveGeometry geometry,
	GeometrySection bendSection,
	BendSurface surface
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains cylindricalSection.
bendSection
Type: Tekla.Structures.ModelGeometrySection
Geometry section to modify.
surface
Type: Tekla.Structures.ModelBendSurface
The modified bend surface for the section.

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not modify the bend surface.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next