SpiralBeam Class

A class for the spiral beam part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class SpiralBeam : Part

The SpiralBeam type exposes the following members.

Constructors
  NameDescription
Public methodSpiralBeam
Initializes a new instance of the SpiralBeam class.
Public methodSpiralBeam(Point, Point, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters. Rotation axis direction is current positive Z direction.
Public methodSpiralBeam(Point, Point, Point, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters.
Public methodSpiralBeam(Point, Point, Point, Double, Double, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters.
Top
Properties
  NameDescription
Public propertyAssemblyNumber
Gets or sets the assembly number. Defines the numbering in the assembly sense.
(Inherited from Part.)
Public propertyCastUnitType
Gets or sets the cast unit type of the part.
(Inherited from Part.)
Public propertyClass
Gets or sets the class of the part.
(Inherited from Part.)
Public propertyDeformingData
Gets or sets the deforming data of the part.
(Inherited from Part.)
Public propertyEndPoint
Gets the spiral beam end point.
Public propertyFinish
Gets or sets the finish of the part.
(Inherited from Part.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyMaterial
Gets or sets the material the part is made of.
(Inherited from Part.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the part.
(Inherited from Part.)
Public propertyPartNumber
Gets or sets the part number. Defines the numbering in the part sense.
(Inherited from Part.)
Public propertyPosition
Gets or sets the part position. Defines the way the part is positioned in the model.
(Inherited from Part.)
Public propertyPourPhase
Gets or sets the pour phase of the part.
(Inherited from Part.)
Public propertyProfile
Gets or sets the profile of the part.
(Inherited from Part.)
Public propertyRotationAngle
Gets or sets the rotation of the spiral beam in degrees. Each range of 360.0 degrees adds a full rotation.
Public propertyRotationAxisBasePoint
Gets or sets the first definition point of the spiral beam rotation axis.
Public propertyRotationAxisDirection
Gets the direction of the spiral beam rotation axis.
Public propertyRotationAxisUpPoint
Gets or sets the second definition point of the spiral beam rotation axis.
Public propertyRotationCenterPoint
Gets the geometric rotation center point at the start of the spiral beam.
Public propertyStartPoint
Gets or sets the start point of the spiral beam.
Public propertyTotalRise
Gets or sets the difference between the spiral beam start and end point in the direction of the rotation axis.
Public propertyTwistAngleEnd
Gets or sets the twist angle in degrees at the end of the spiral beam.
Public propertyTwistAngleStart
Gets or sets the twist angle in degrees at the start of the spiral beam.
Top
Methods
  NameDescription
Public methodCompareTo(Object)
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodCompareTo(Part)
Compares the instantiated part with another one.
(Inherited from Part.)
Public methodDelete
Deletes the spiral beam with this instance identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the part belongs to.
(Inherited from Part.)
Public methodGetBolts
Returns an enumerator of all the connected bolts.
(Inherited from Part.)
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
(Inherited from Part.)
Public methodGetCenterLine
Returns the center line for the given part.
(Inherited from Part.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetComponents
Returns an enumerator of all the connected components, connections, seams and details inherited from the base component.
(Inherited from Part.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDSTVCoordinateSystem
Get DSTV coordinate system.
(Inherited from Part.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPartMark
Returns the part mark.
(Inherited from Part.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetPours
Returns an enumerator of all the pours that the part belongs to.
(Inherited from Part.)
Public methodGetReferenceLine
Returns the reference line for the given part.
(Inherited from Part.)
Public methodGetReinforcements
Returns an enumerator of all the connected reinforcements.
(Inherited from Part.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Returns the solid of the part.
(Inherited from Part.)
Public methodGetSolid(FormingStates)
Returns the solid of the part.
(Inherited from Part.)
Public methodGetSolid(SolidSolidCreationTypeEnum)
Returns the solid of the part.
(Inherited from Part.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetSurfaceObjects
Returns an enumerator of all the connected surface objects.
(Inherited from Part.)
Public methodGetSurfaceTreatments
Returns an enumerator of all the connected surface treatments.
(Inherited from Part.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodGetWelds
Returns an enumerator of all the connected welds.
(Inherited from Part.)
Public methodInsert
Inserts the spiral beam into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the spiral beam object values in the database.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a spiral beam object from the database.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public bool SimpleExample()
       {
           var startPoint = new Point(0.0, 0.0, 0.0);
           var centerPoint = new Point(200.0, 0.0, 0.0);
           var totalRise = 100.0;
           var rotationAngle = 90.0;

           SpiralBeam spiral = new SpiralBeam(startPoint, centerPoint, totalRise, rotationAngle);
           spiral.Profile.ProfileString = "U300";
           return spiral.Insert();
       }

       public bool FullExample()
       {
           var startPoint = new Point(0.0, 0.0, 0.0);
           var rotationAxisPoint1 = new Point(200.0, 0.0, 0.0);
           var rotationAxisPoint2 = new Point(200.0, 0.0, 1000.0);
           var totalRise = 1000.0;
           var rotationAngle = 1080.0;
           var twistAngleStart = 10.0;
           var twistAngleEnd = 30.0;

           SpiralBeam spiral = new SpiralBeam(startPoint, rotationAxisPoint1, rotationAxisPoint2, totalRise, rotationAngle, twistAngleStart, twistAngleEnd);
           spiral.Profile.ProfileString = "HEA400";
           spiral.Material.MaterialString = "Steel_Undefined";

           bool result = spiral.Insert();
           return result;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next