SpiralBeam Class

A class for the spiral beam part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class SpiralBeam : Part

The SpiralBeam type exposes the following members.

Constructors
  NameDescription
Public methodSpiralBeam
Initializes a new instance of the SpiralBeam class.
Public methodSpiralBeam(Point, Point, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters. Rotation axis direction is current positive Z direction.
Public methodSpiralBeam(Point, Point, Point, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters.
Public methodSpiralBeam(Point, Point, Point, Double, Double, Double, Double)
Initializes a new instance of the SpiralBeam class with the given parameters.
Top
Properties
  NameDescription
Public propertyEndPoint
Gets the spiral beam end point.
Public propertyRotationAngle
Gets or sets the rotation of the spiral beam in degrees. Each range of 360.0 degrees adds a full rotation.
Public propertyRotationAxisBasePoint
Gets or sets the first definition point of the spiral beam rotation axis.
Public propertyRotationAxisDirection
Gets the direction of the spiral beam rotation axis.
Public propertyRotationAxisUpPoint
Gets or sets the second definition point of the spiral beam rotation axis.
Public propertyRotationCenterPoint
Gets the geometric rotation center point at the start of the spiral beam.
Public propertyStartPoint
Gets or sets the start point of the spiral beam.
Public propertyTotalRise
Gets or sets the difference between the spiral beam start and end point in the direction of the rotation axis.
Public propertyTwistAngleEnd
Gets or sets the twist angle in degrees at the end of the spiral beam.
Public propertyTwistAngleStart
Gets or sets the twist angle in degrees at the start of the spiral beam.
Top
Methods
  NameDescription
Public methodDelete
Deletes the spiral beam with this instance identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodInsert
Inserts the spiral beam into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the spiral beam object values in the database.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a spiral beam object from the database.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public bool SimpleExample()
       {
           var startPoint = new Point(0.0, 0.0, 0.0);
           var centerPoint = new Point(200.0, 0.0, 0.0);
           var totalRise = 100.0;
           var rotationAngle = 90.0;

           SpiralBeam spiral = new SpiralBeam(startPoint, centerPoint, totalRise, rotationAngle);
           spiral.Profile.ProfileString = "U300";
           return spiral.Insert();
       }

       public bool FullExample()
       {
           var startPoint = new Point(0.0, 0.0, 0.0);
           var rotationAxisPoint1 = new Point(200.0, 0.0, 0.0);
           var rotationAxisPoint2 = new Point(200.0, 0.0, 1000.0);
           var totalRise = 1000.0;
           var rotationAngle = 1080.0;
           var twistAngleStart = 10.0;
           var twistAngleEnd = 30.0;

           SpiralBeam spiral = new SpiralBeam(startPoint, rotationAxisPoint1, rotationAxisPoint2, totalRise, rotationAngle, twistAngleStart, twistAngleEnd);
           spiral.Profile.ProfileString = "HEA400";
           spiral.Material.MaterialString = "Steel_Undefined";

           bool result = spiral.Insert();
           return result;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next