TeklaStructuresInfo Class

The TeklaStructuresInfo class provides information about Tekla Structures.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresTeklaStructuresInfo

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public sealed class TeklaStructuresInfo

The TeklaStructuresInfo type exposes the following members.

Constructors
  NameDescription
Public methodTeklaStructuresInfo
Initializes a new instance of the TeklaStructuresInfo class
Top
Methods
  NameDescription
Public methodStatic memberGetBuildNumber
Returns the Tekla Structures build number.
Public methodStatic memberGetCommonAppDataFolder
Returns (XSDATADIR)environments installation folder of the Tekla Structures as string.
Public methodStatic memberGetCopyRightText
Returns the Tekla Structures copyright text as string.
Public methodStatic memberGetCurrentProgramVersion
Returns the current Tekla Structures version.
Public methodStatic memberGetCurrentUser
Returns the current Tekla Structures user.
Public methodStatic memberGetFullTSRegistryKeyText
Returns full registry key of the Tekla Structures as string.
Public methodStatic memberGetLocalAppDataFolder
Returns (XSUSERDATADIR) user's local appdata folder of the Tekla Structures as string.
Public methodStatic memberGetPluginsFolder
Returns main TS plugins folder, not extensions folder
Public methodStatic memberGetRevisionDate
Returns the Tekla Structures revision date as string.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next