OperationIsNumberingUpToDate Method

Checks whether the numbering is up-to-date for an assembly, part, rebar, surface treatment, pour object or break.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool IsNumberingUpToDate(
	ModelObject InputModelObject
)

Parameters

InputModelObject
Type: Tekla.Structures.ModelModelObject
The model object to check. The object must be an assembly, a part, a rebar or an inherited object.

Return Value

Type: Boolean
True if the numbering information is up-to-date.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the InputModelObject is not of a correct type or if it is not valid.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next